Commit 1d3eacdb authored by Jonatan Zint's avatar Jonatan Zint
Browse files

update app for 2022

parent 769c3cf7
Pipeline #11000 failed with stages
in 31 seconds
......@@ -44,7 +44,7 @@ module.exports = {
'prefer-promise-reject-errors': 'off',
// allow console.log during development only
'no-console': process.env.NODE_ENV === 'production' ? 'error' : 'off',
'no-console': 'off',
// allow debugger during development only
'no-debugger': process.env.NODE_ENV === 'production' ? 'error' : 'off'
}
......
......@@ -9,7 +9,7 @@ build:
paths:
- dist/pwa/
script:
- npm i
- npm ci
- npx quasar build -m pwa
cache:
paths:
......@@ -19,6 +19,6 @@ deploy:
image: instrumentisto/rsync-ssh:latest
stage: deploy
script:
- rsync --delete -rvz dist/pwa/ deploy@epikur.hedonist-international.org::info2019
- rsync -e 'ssh -p 22016' --delete -rvz dist/pwa/ info2022deploy@65.108.159.16:.
only:
- master
\ No newline at end of file
- master
This diff is collapsed.
{
"name": "kyrene",
"version": "0.0.1",
"description": "Schedule of the Hedonist Worldcongress 2019",
"description": "Schedule of the Hedonist Worldcongress 2022",
"productName": "Kyrene",
"cordovaId": "org.hedonist-international.kyrene",
"author": "Jonatan Zint <jonatan@ctrl.alt.coop>",
"private": true,
"scripts": {
......@@ -11,27 +10,29 @@
"test": "echo \"No test specified\" && exit 0"
},
"dependencies": {
"@quasar/extras": "^1.0.0",
"@quasar/extras": "^1.13.6",
"axios": "^0.18.0",
"jquery": "^3.4.1",
"moment": "^2.24.0",
"pinch-zoom-js": "^2.3.4",
"quasar": "^1.0.0-beta.0",
"quasar": "^1.18.10",
"urljoin": "^0.1.5",
"vue-i18n": "^7.3.3",
"vuex-persistedstate": "^2.5.4"
},
"devDependencies": {
"@quasar/app": "^1.0.0-beta.0",
"@quasar/cli": "^1.0.0-rc.2",
"@quasar/app": "^2.3.0",
"@quasar/cli": "1.3.2",
"@vue/eslint-config-prettier": "^4.0.1",
"babel-eslint": "^10.0.1",
"core-js": "^3.22.5",
"eslint": "^5.10.0",
"eslint-config-prettier": "^4.3.0",
"eslint-loader": "^2.1.1",
"eslint-plugin-vue": "^5.0.0",
"pug": "^2.0.3",
"pug-plain-loader": "^1.0.0"
"pug-plain-loader": "^1.0.0",
"workbox-webpack-plugin": "^5.1.4"
},
"engines": {
"node": ">= 8.9.0",
......@@ -39,6 +40,14 @@
"yarn": ">= 1.6.0"
},
"browserslist": [
"last 1 version, not dead, ie >= 11"
"last 10 Chrome versions",
"last 10 Firefox versions",
"last 4 Edge versions",
"last 7 Safari versions",
"last 8 Android versions",
"last 8 ChromeAndroid versions",
"last 8 FirefoxAndroid versions",
"last 10 iOS versions",
"last 5 Opera versions"
]
}
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment